NZ Female Pelvic Mesh Service (Southern hub)

Incident Report for HealthLink Service Status

Resolved

This incident has been resolved.
Posted May 06, 2026 - 14:12 NZST

Investigating

Customers will not be able to submit the form
Posted May 06, 2026 - 12:39 NZST
This incident affected: New Zealand - HealthLink Smart Forms (HealthLink Smart Form - NZ Female Pelvic Mesh Service (Southern hub)).